Connection: via IPv4
Your IP : 44.212.99.208
In English
Categories: NEC

NEC UNIVERGE IX2215でroute_mapを使ったPBR

概要

最近安価に調達しやすくなってきたNEC UNIVERGE IX2215で送信元IP(src)や送信先IP(dest)によるデフォルトゲートウェイの振り分けを行う設定例です。

関連キーワード: マルチISP SD-WAN

 

前提条件

  • IX2215をコンソールやsshで操作できる
  • 操作を誤ってインターネットが見られなくなっても自力で復旧できる

設定方法

手順がやや複雑ですが、流れは以下の通りです。

また、IX2215が唯一のインターネットへの接続点の場合、6番目は必ず最後に設定するべきです。

  1. access listを作る
  2. route_mapで上記access listにmatchするときdefault interfaceを変えるルールを設定する
  3. route_mapでmatchを設定していないルールを最低優先度で設定する(ip route defaultの代わり)
  4. ip local policy/ipv6 local policy でroute_mapを指定する
  5. 各interfaceでip policy/ipv6 policyにroute_mapを指定する
  6. (!重要) ip route default/ipv6 route defaultを削除する
    1. ここでインターネットに繋がらなくなった場合、route_mapの設定に問題があります
    2. この値がある場合、route_mapのdefault interfaceは無視されます。これはroute_mapのdefault interfaceよりip route/ipv6 routeの優先順位が高いためです。

設定例

関係のあるコンフィグの抜粋です

PPPoE IPv4の接続先2つを送信元IPで切り換える

! 
ip access-list client permit ip src 192.168.0.0/24 dest any
ip access-list server permit ip src 192.168.1.0/24 dest any
ip local policy route-map pppoesw
!
route-map pppoesw permit 9
  match ip address access-list server
  set default interface GigaEthernet0.1
!
route-map pppoesw permit 10
  match ip address access-list client
  set default interface GigaEthernet0.2
!
route-map pppoesw permit 99
  set default interface GigaEthernet0.1
!
interface GigaEthernet2.0
  ip address 192.168.0.1/24
  ip policy route-map pppoesw
!
interface GigaEthernet2.1
  ip address 192.168.1.1/24
  ip policy route-map pppoesw
!
exit
!
no ip route default

インターネット接続先(DHCP/Static)2つを送信元IPで切り換える

! 
ip access-list client permit ip src 192.168.0.0/24 dest any
ip access-list server permit ip src 192.168.1.0/24 dest any
ip local policy route-map ifsw 
!
route-map ifsw permit 9
  match ip address access-list server
  set default interface GigaEthernet0.0
!
route-map ifsw permit 10
  match ip address access-list client
  set default interface GigaEthernet1.0
  set ip default next-hop 172.16.0.1
!
route-map ifsw permit 99
  set default interface GigaEthernet0.0
!
interface GigaEthernet1.0
  ip address dhcp
!
interface GigaEthernet2.0
  ip address 172.16.0.2/24
!
interface GigaEthernet2.0
  ip address 192.168.0.1/24
  ip policy route-map ifsw 
!
interface GigaEthernet2.1
  ip address 192.168.1.1/24
  ip policy route-map ifsw 
!
exit
!
no ip route default

 

This post was last modified on 2023年12月18日 2:59 PM

Share
Published by
おきん(blog)

Recent Posts

[メモ]JellyfinでEntraID認証

概要 メディアサーバーのJel…

2週間 ago

MastodonでhCaptchaを使う

概要 Mastodonサーバー…

2か月 ago

Redisを6.0から7.xに更新する

概要 Ubuntu 22.04…

2か月 ago

CodiMDでEntra IDを使う

出来ること CodiMDのログ…

2か月 ago

CloudflareをDDNSみたいに使う

やりたいこと Cloudfla…

3か月 ago

This website uses cookies.